Firefox 74

Firefox 74 is not yet supported out of the box.

If you want a supported setup, you can use Firefox ESR, Chrome, Brave, Pale Moon, or Vivaldi instead.

If you install Pluckeye while using Firefox 73, and then upgrade to Firefox 74, Firefox 74 should continue to work with Pluckeye.

If you want to use Firefox 74 and you haven't got Firefox 73, you can install this Firefox addon, but you'll very likely have to manually uninstall the addon at a future date when pluckeye does start supporting firefox 74+. Don't forget this!